Saturday, September 02, 2006

Upgrade Engines to work with Rails 1.1.6

My Rails app at just broke as Textdrive have upgraded Rails to 1.1.6 and the version of Engines, Log Engine and User Engine I had was not compatible with Rails 1.1.6. I removed the folder engines, login_engine and user_engine under RAILS_ROOT/vendor/plugins and installed engines, login_engine and user_engine using script/plugin, restarted rails and everything was nice and dandy again. Using engines with Rails is slightly risky in this regard as almost every new version of Rails seems to break them. DHH did not had any good words to say about Engines at RailsConf in Chicago.

No comments: